Stop data retention! Click here & act! Are you a webmaster and want to participate? Here you can find all necessary material for your website - Willst du auch an der Aktion teilnehmen? Hier findest du alle relevanten Infos und Materialien:
Chris Karakas Online Forum Index Karakas Online
 FAQFAQ   Forum SearchForum Search   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
How to setup font size and appearence correctly in Linux



 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
   Chris Karakas Online Forum Index -> Linux Forum RSS Feed of this Forum
Share this page: These icons link to social bookmarking sites where readers can share and discover new web pages.Digg  del.icio.us  tc.eserver.org  Blinklist  Furl  Reddit  Blogmarks  Magnolia  Sphere  Yahoo!  Google  Windows Live  Technorati  Blue Dot  Simpy  Newsvine  Stumble Upon  co.mments.com  Blinkbits  BlogMemes  Connotea  View previous topic :: View next topic  
Author Message
chris
Dark Lord of the Sith


Joined: 10 May 2003
Posts: 6267
Location: Outer Space

PostPosted: Fri Feb 24, 2006 12:09 pm    Post subject: How to setup font size and appearence correctly in Linux
Reply with quote

Question Problem: You have tiny font sizes all around in your brand new Linux system. Maybe you managed to get larger fonts inside the applications windows, but the menus, the menu items, the icon texts, the window titles - all scream for a magnifying lens, in order to be read! Sad Sad Sad

Arrow Cause: OMG, the Cause...Rolling Eyes...Well, forget about the cause. The cause is that there are too many places in Linux that may have an influence on font size. You may have KDE, GNOME, a font server, X fonts, applications that use Qt, others that use GTK+, others that don't use either of them and so on. We are looking for a "one point of control" solution. Something that you can change and be happy with all your applications, not just with your window manager, or Mozilla, or Acrobat.

Idea Idea: Your resolution may be correct, but your DPI (dots per inch) is NOT! Correct that and be happy! Very Happy

Arrow Solution: First of all, it doesn't make any sense to continue if you don't have the basics configured correctly. And the basics are:

  • An understanding of how fonts work in Linux. Go get Optimal Use of Fonts on Linux and read it from top to bottom with a cup of your favourite beverage. Smile
  • A recent X Server. "Recent" for our purposes is any version starting from 4.3 and later. That's an easy requirement to fulfill today, as 4.3 is rather old.
  • A web browser with Xft support. I use Mozilla and to get the package with Xft support I always have to click on "Other" on the Mozilla site. Then I grab the package named mozilla-i686-pc-linux-gnu-X.Y.Z-gtk2+xft.tar.gz, where X.Y.Z may be 1.7.8, or 1.7.12, or whatever the current version is.
  • The new 7.x Acrobat Reader from the Adobe site.
  • Any recent version of KDE or GNOME or both. "Recent" covers the last 3 years at least, so you should be safe with whichever version you happen to have today.
  • Freetype fonts and the freetype 2.x library. And any other nice fonts you might need - see the document above for details. In my (SuSE) system, I have:
    • ghostscript-fonts-std-7.07.1rc1-37
    • XFree86-fonts-75dpi-4.3.0.1-21
    • XFree86-fonts-100dpi-4.3.0.1-21
    • ghostscript-fonts-other-7.07.1rc1-37
    • XFree86-fonts-scalable-4.3.0.1-21
    • free-ttf-fonts-1.0-64

    Believe me, you will never use all these fonts in your whole life! Laughing
  • Fontconfig. That is, the packages
    • fontconfig-2.2.1-58
    • fontconfig-devel-2.2.1-58
  • The Xfs font server. The Xfs font server comes with XFree86 (or xorg), so don't look for an RPM package - you alraedy have it. Smile Configure it as follows:
    Enter the line:

    Code:

    FontPath   "unix/:7100"


    in your X configuration file (which is either XF86Config, or xorg.conf in /etc/X11/, depending on whether you have XFree86 of Xorg installed), before all other FontPath lines, then comment those lines. It should look as follows:

    Code:

        FontPath   "unix/:7100"
    #    FontPath   "/usr/X11R6/lib/X11/fonts/latin7/75dpi"
    #    FontPath    "/usr/X11R6/lib/X11/fonts/misc/"
    #    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    #    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/"
    #    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    #    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/"
    #    FontPath    "/usr/X11R6/lib/X11/fonts/Type1/"
    #    FontPath    "/usr/X11R6/lib/X11/fonts/truetype/"


    or similar, depending on how many FontPath lines you have there. Again, comment them all and leave only the "unix/:7100" line uncommented.
  • Tell your X server to load the freetype and type1 modules. I have:

    Code:

    Section "Module"
        Load       "dbe"
        SubSection "extmod"
          Option   "omit xfree86-dga"
        EndSubSection
        Load       "type1"
        Load       "freetype"
        Load       "speedo"
        Load       "extmod"
        Load       "xie"
        Load       "pex5"
        Load       "glx"
    #    These modules MUST be removed when using the nVidia driver!
    #    Load       "dri"
    #    Load       "GLcore"
        Load       "record"
    EndSection
    Section "DRI"
         Mode 0666
    EndSection


    in my XF86Config for an nVidia 6800 card. The important entries for us here are those for freetype and type1.
  • Configure Xfs. Open the /etc/X11/fs/config file and change the line:

    Code:

    default-resolutions = 100,100,75,75


    to reflect your DPI. If you have a DPI (we'll talk about it later) that is rather near to 100, use the above line, if ot is rather near the 75, use:

    Code:

    default-resolutions = 75,75,100,100


    The reason is: the font packages you installed come with two standard DPIs: 75 and 100. The other DPIs are "computed" from those. The above line tells Xfs which DPI to use as a "first guess": the 75x75 one, or the 10x100 one (that's why you see those numbers twice there).
    You may also want to change the default point size:

    Code:

    # in decipoints
    default-point-size = 120


    but I would at first leave it as is. While you are at it, have a look at the "catalogue" variable in the same file:

    Code:

    # Changed by root.
    # Added /opt/kde3/share/fonts, /opt/OpenOffice.org/share/fonts/truetype
    # and /usr/share/xine/libxine1/fonts.
    catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled,
                /usr/X11R6/lib/X11/fonts/75dpi:unscaled,
                /usr/X11R6/lib/X11/fonts/100dpi:unscaled,
                /usr/X11R6/lib/X11/fonts/japanese:unscaled,
                /usr/X11R6/lib/X11/fonts/baekmuk:unscaled,
                /usr/X11R6/lib/X11/fonts/Type1,
                /usr/X11R6/lib/X11/fonts/URW,
                /usr/X11R6/lib/X11/fonts/Speedo,
                /usr/X11R6/lib/X11/fonts/CID,
                /usr/X11R6/lib/X11/fonts/PEX,
                /usr/X11R6/lib/X11/fonts/cyrillic,
                /usr/X11R6/lib/X11/fonts/latin2/misc,
                /usr/X11R6/lib/X11/fonts/latin2/75dpi,
                /usr/X11R6/lib/X11/fonts/latin2/100dpi,
                /usr/X11R6/lib/X11/fonts/latin2/Type1,
                /usr/X11R6/lib/X11/fonts/latin7/75dpi,
                /usr/X11R6/lib/X11/fonts/kwintv,
                /usr/X11R6/lib/X11/fonts/truetype,
                /usr/X11R6/lib/X11/fonts/uni,
                /usr/X11R6/lib/X11/fonts/ucs/misc,
                /usr/X11R6/lib/X11/fonts/ucs/75dpi,
                /usr/X11R6/lib/X11/fonts/ucs/100dpi,
                /usr/X11R6/lib/X11/fonts/hellas/misc,
                /usr/X11R6/lib/X11/fonts/hellas/75dpi,
                /usr/X11R6/lib/X11/fonts/hellas/100dpi,
                /usr/X11R6/lib/X11/fonts/hellas/Type1,
                /usr/share/texmf/fonts/,
                /opt/kde3/share/fonts,
                /opt/OpenOffice.org/share/fonts/truetype,
                /usr/share/xine/libxine1/fonts,
                /usr/X11R6/lib/X11/fonts/cm-unicode


    As you can see, I have changed mine and added some paths to other fonts (like KDE, OpenOffice, xine or Computern Modern Unicode, that I happen to have installed). You are not required to do so yourself. The catalogue variable tells Xfs which fonts to serve and where to get them from (and probably in which order too...). So if you absolutely want to also be able to use the OpenOffice fonts (and why shouldn't you want to Smile), then you should of course add the line

    Code:

    /opt/OpenOffice.org/share/fonts/truetype,


    as I have done above. Again, the important thing is that you at least see all your X fonts there, including the truteype ones from the free-ttf-fonts package.
  • Make sure the Xfs server is configured to start at system start. Use the "Runlevel editor" in SuSE to achieve this. Say "yes" for "xfs".
  • I will not go into the details of correct font installation (i.e. how you get all those fonts.alias files, the font metric files etc.etc.). Usually, all this is taken care of by your distribution when you install the files. Should you install a font manually, make sure you added its path to the Xfs configuration file above AND to the fontconfig configuration file in /etc/fonts/local.conf (look at /etc/fonts/fonts.conf for how this is done, but do your additions only in /etc/fonts/local.conf), THEN call

    Code:

    fonts-config -f -v


    to create all that is needed for those fonts (that's where the fontconfig package comes handy! Wink).
  • If you later find out that you don't like antialiasing for, say, fonts of size smaller than 15 points, then you can control this from the /etc/fonts/local.conf file:

    Code:

    <!--    Changed by root.
            Inserted.
            How to disable antialising for fonts of size less than 15
            Don't do it - looks awful...

    -->
    <!--
            <match target="font">
                <test name="size" compare="less">
                    <double>15</double>
                </test>
                <edit name="antialias" mode="assign">
                    <bool>false</bool>
                </edit>
            </match>
            <match target="font">
                <test name="pixelsize" compare="less" qual="any">
                    <double>15</double>
                </test>
                <edit mode="assign" name="antialias">
                    <bool>false</bool>
                </edit>
            </match>
    -->


    Just take away the comment lines (those with the "<!--" and "-->" that enclose the XML code. Use an editor with syntax highlighting enabled (like vi, as explained in Sexy vi Wink), to make sure you didn't break things by taking out the wrong lines. Again, this is not something that should bother you right now, because right now you only want to get rid of those tiny fonts. Wink


Arrow Enough basics! On to the fun part! Laughing

Restart your X. If you did everything right, you should see, fine, antialiased, smooth fonts all around. But one problem remains: menus, menu items, icon texts, window titles are all tiny, miniscule, unreadable - but yes, fine and smooth, if you get your magnifying lens and get real close... Evil or Very Mad

Sure, you can go the KDE control center and change the font settings - for all KDE applications. But what about GNOME apps? Will you go to the GNOME control panel to do the same? And what about my FVWM window manager? How will you correct its tiny window titles and menus? And Acrobat Reader? Well, you might be lucky with that one if you change your GTK settings.

Oh well, what a mess...go there, do that - only to find out that you changed only one aspect of your problem, but not THE PROBLEM!

What happens? Remember our idea at the start? Let's state it again here:

Idea Idea: Your resolution may be correct, but your DPI (dots per inch) is NOT! Correct that and be happy! Very Happy

Oops...DPI hit me again! Shocked

How come? I thought the DPI is determined by the X server during the start: it asks the monitor for its resolution and DPI. If the monitor is somewhat recent, it should tell it "my DPI is XYZ", right?

Well, right and wrong. It turns out that, no matter what your monitor says, or does not say, there is only one definitive, undisputable, infallible way to find out YOUR DPI: measure it yourself!

Believe me, it will cost you only 5 minutes, but will save you days of searching for the solution - so let's do it: go get a rule and measure your visible screen in the horizontal direction. That's, say, 28,5 centimeters. Divide that by 2,5. Gives you 11,4 inches. So your visible display is 11,4 inches wide. What's your current resolution? Say 1024x768. That's 1024 dots in 11,4 inches. How many Dots Per Inch is that? My xcalc program says 1024/1,4=89,82 and I believe it. Laughing

So the horizontal DPI is 90 (taking into account small measuring errors due to my overcoffeinated, trembling hand Laughing).

Do the same for the vertical direction, i.e. the height of your visible part on the display. For me, it turned out that the number was again very close to 90.

Conclusion: the DPI is 90! Go tell your X server!

As I use the KDM for graphical logins in that other laptop, I had to open /etc/opt/kde3/share/config/kdm/Xservers file and change

Code:

:0 local /usr/X11R6/bin/X vt7


to

Code:

:0 local /usr/X11R6/bin/X -dpi 90 vt7


Restart X - for this, it suffices to logoff and let kdm restart your X and present you the login screen. Voilą! Everything looks fine now! Enjoy a really pleasant system! Very Happy

Some remarks:
  • You will find "solutions" on the Internet, that tell you to use a lower resolution. This is not a solution. It is "messing around with the symptoms"! Quite the contrary, with the right DPI, you should use the maximum possible (the native) resolution on your laptop or LCD displays (i.e. on all displays other than CRT ones). This will make your fonts really crystal clear, crisp and smooth. Using a lower resolution on a flat display always makes my fonts look "dirty", due to antialiasing - but is is NOT the antialiasing that is the culprit here, it is the lame resolution setting!
  • You will also find solutions that tell you to change some font setting in your personal .gtk2something file. Again, this is not a solution. It takes care of GTK+ applications, but leaves you in the rain for all others. The same is true for any solutions that use the KDE control center - they cater for only the Qt apps. But as we have seen, the root of the problem lies much deeper - in one sole number that is wrong: your DPI!
  • Choose Adobe or Bitstream fonts in the Fonts preferences of Mozilla. Do this for all encodings you think that you will encounter (for me these are Western, Unicode and Greek - YMMV Wink). These fonts look really nice!


That's all! Enjoy! Very Happy
_________________
Regards

Chris Karakas
www.karakas-online.de


Last edited by chris on Wed Jul 02, 2008 9:08 am; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail Visit poster's website
chris
Dark Lord of the Sith


Joined: 10 May 2003
Posts: 6267
Location: Outer Space

PostPosted: Fri Feb 24, 2006 6:42 pm    Post subject:
Reply with quote

Well, contrary to my assertion above, it seems that, at least for laptops, I get a crisper (but still smooth) appearence by NOT using antialiasing - and by using sub-pixel rendering!

This seems to be an area where each laptop display, each resolution and probably even each pair of eyes give a slightly different result.

What you can do? You can experiment with sub-pixel rendering (rgb or bgr), anti-alias, auto-hinting in the /etc/fonts/local.conf file. Do your changes there and restart Mozilla. You can see that Mozilla (and all other modern applications that use the same methods for their font rendering) reads this file each time before it starts by simply introducing deliberately an error in the file - Mozilla will complain about it (at least if you start it by typing "mozilla" on the command line, that is Wink).

After a lot of experimentation, I found that sub-pixel rendering brings a lot on a laptop with 1024x768 resolution, but does not seem to be very noticeable on a 1680x1024 one. Of course, you have more than double as many pixels on 1680x1050 than on 1024x768, so this alone may be the reason...

I suggest you experiment yourself and take your time to choose what fits you best. Here are the settings in /etc/fonts/local.conf that worked for me:

Code:

<!--
  Enable sub-pixel rendering
-->
        <match target="font">
                <test qual="all" name="rgba">
                        <const>unknown</const>
                </test>
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>

<!-- Autohint fonts -->
        <match target="font">
                <edit name="autohint" mode="assign"><bool>true</bool> </edit>
        </match>


and here are some commented ones for you to experiment with: Mr. Green

Code:

<!-- Use Bitstream Vera fonts by default -->
<!--
        <alias>
                <family>serif</family>
                <prefer>
                        <family>Bitstream Vera Serif</family>
                </prefer>
        </alias>
        <alias>
                <family>sans-serif</family>
                <prefer>
                        <family>Bitstream Vera Sans</family>
                </prefer>
        </alias>
        <alias>
                <family>monospace</family>
                <prefer>
                        <family>Bitstream Vera Sans Mono</family>
                </prefer>
        </alias>

-->
<!-- Antialias -->

<!--
<match target="font">
        <test qual="any" name="size" compare="more">
                <double>14</double>
        </test>
        <test qual="any" name="size" compare="less">
                <double>20</double>
        </test>
        <edit name="antialias" mode="assign">
                <bool>true</bool>
        </edit>
</match>
-->


Happy experimentation! And don't forget to report here what worked for you! Very Happy
_________________
Regards

Chris Karakas
www.karakas-online.de
Back to top
View user's profile Send private message Send e-mail Visit poster's website
chris
Dark Lord of the Sith


Joined: 10 May 2003
Posts: 6267
Location: Outer Space

PostPosted: Wed Jul 02, 2008 8:40 am    Post subject: Re: How to get rid of tiny font sizes in all Linux applicati
Reply with quote

chris wrote:
Open quoteAfter a lot of experimentation, I found that sub-pixel rendering brings a lot on a laptop with 1024x768 resolution, but does not seem to be very noticeable on a 1680x1024 one. Close quote


Well, not sure how I checked my above claim at the time I wrote it, but boy does it make a difference! And I found it out the hard way (as so often...):

I wanted to install some programs (poppler, which is needed by pdf2djvu, see my posts in Dependencies for pdf2jvu), which in turn needed Cairo. I had a very old (SuSE 9.0) version of it (0.3.0-3) and I needed a newer one, so I grabbed, compiled and installed cairo-1.6.4. Due to some missing .pc file for pkgconfig (a configure script was telling me that I don't have freetype installed Rolling Eyes), I also upgraded to a SuSE 9.3 freetype2-2.1.9-4.

All seemed to work fine together, the very current cairo 1.6.4 and the very old freetype 2.1.9, I could finally install my programs...

...until I opened Seamonkey and almost got eye cancer from looking at the fonts! A very annoying colour fringe was surrounding the letters! Sure, subpixel rendering was the culprit! Of course, you can never totally eliminate some idea of a colour around some places of the text, but what I was seeing was too much of that.

A lengthy, painful search for the cause of the problem started. At the end I found out that freetype has a better autohinter starting from version 2.2, so I downloaded a SuSE 10.2 freetype 2.3.5, compiled an RPM for it and installed it.

Now everything is fine again. Smile

To save you some trial-and-error attempts, here is what I found in the process:

  • It is NOT a problem of an old fontconfig. I have fontconfig-2.2.99.20050218-8 - not the newest one. It IS something that has to do with freetype, autohinting, good or bad fonts (read: fonts with good or bad hintig).
  • It does NOT (seem to) have to do with "bytecode hinting" (see hinting for more details), that thing that you may enable when you compile freetype at the risk of infringing some patent.
  • It does NOT have to do with the filter settings

    Code:

      <match target="font">
        <edit name="lcdfilter" mode="assign"><const>lcdfilterlegacy</const></edit>
        <edit name="hintstyle" mode="assign"><const>hintfull</const></edit>
      </match>


    in /etc/fonts/local.conf that are suggested in Fixing the font rendering in Ubuntu 8.04. Maybe my versions are still too old for those settings to take effect - maybe they are old enough to avoid the problem that they solve... Laughing
  • You DONT need to enable antialiasing with something like

    Code:

    <!-- Antialias -->

    <!--
    <match target="font">
            <test qual="any" name="size" compare="more">
                    <double>14</double>
            </test>
            <test qual="any" name="size" compare="less">
                    <double>20</double>
            </test>
            <edit name="antialias" mode="assign">
                    <bool>true</bool>
            </edit>
    </match>
    -->


    in /etc/fonts/local.conf either. Just leave the antialising code commented.
  • You DO need to enable subpixel rendering with

    Code:

    <!--
      Enable sub-pixel rendering
    -->
            <match target="font">
                    <test qual="all" name="rgba">
                            <const>unknown</const>
                    </test>
                    <edit name="rgba" mode="assign"><const>rgb</const></edit>
            </match>


    AND also autohinting with

    Code:

    <!-- Autohint fonts -->
            <match target="font">
                    <edit name="autohint" mode="assign"><bool>true</bool> </edit>
            </match>


So what's the difference between subpixel rendering and no subpixel rendering at all? Here it is:


With subpixel rendering and autohinting both enabled:

See Subpixel rendering and autohinting both enabled for an enlargement.
Image

With subpixel rendering disabled but autohinting still enabled:

See Subpixel rendering disabled but autohinting still enabled for an enlargement.
Image


With subpixel rendering and autohinting both disabled:

See Subpixel rendering and autohinting both disabled for an enlargement.
Image

All three images are with Seamonkey in Linux. The third one "looks like Internet Explorer" for me. I guess that's how a Windows user sees my Forum (if he allows pages to "use their own fonts"). Looks nice and somehow "airy" - but somehow too "thin" too. Compare with the first one, which is what I daily see - both are Verdana, but I guess you've never seen Verdana like in the first image, did you? That's the difference of subpixel rendering!

When I was writing my remark at the top of this post, I guess I was comparing the first and the second image, i.e. the effect of subpixel rendering with autohinting enabled all the time. So there IS a difference after all - but you see it only after you disable autohinting, in which case you get the classical "Windows-Verdana" look.
_________________
Regards

Chris Karakas
www.karakas-online.de
Back to top
View user's profile Send private message Send e-mail Visit poster's website
chris
Dark Lord of the Sith


Joined: 10 May 2003
Posts: 6267
Location: Outer Space

PostPosted: Wed Jul 02, 2008 8:56 am    Post subject:
Reply with quote

As said above, for subpixel rendering to work, you will have to apply autohinting. However, you may find that you don't need autohinting for all fonts or all font sizes. If you find that you want to apply autohinting selectively here's how to do it in your /etc/fonts/local.conf file:

Code:

<!-- disable authint for all fonts -->
<!--
    <match target="font">
        <edit mode="assign" name="autohint">
            <bool>false</bool>
        </edit>
    </match>

<!-- enable it for Sans Serif fonts smaller than 12 points  -->
     <match target="font">
        <test name="family">
            <string>Sans</string>
        </test>
        <test compare="less" name="size" qual="any">
          <double>12</double>
        </test>
        <edit name="autohint" mode="assign">
            <bool>true</bool>
        </edit>
    </match>

-->

    <!-- Arial and Verdana  -->
    <!-- enable for Arial only when it is too small -->
<!--
    <match target="font">
        <test name="family">
            <string>Arial</string>
        </test>
        <test compare="less" name="size" qual="any">
          <double>10</double>
        </test>
        <edit name="autohint" mode="assign">
            <bool>true</bool>
        </edit>
    </match>
-->
    <!-- but keep disabled on bold -->
<!--
    <match target="font">
        <test name="family">
            <string>Arial</string>
        </test>
         <test name="weight" compare="more">
             <const>medium</const>
         </test>
         <edit name="autohint" mode="assign">
             <bool>false</bool>
         </edit>
     </match>

-->

     <!-- now enable for verdana so that it looks nice above 9 and below 7 -->
<!--
     <match target="font">
        <test name="family">
            <string>Verdana</string>
        </test>
        <test compare="less" name="size" qual="any">
          <double>9</double>
        </test>
        <edit name="autohint" mode="assign">
            <bool>true</bool>
        </edit>
    </match>
-->
    <!-- when it it too small it starts to look crappy, so we keep autohinting disabled -->
<!--
    <match target="font">
        <test name="family">
            <string>Verdana</string>
        </test>
        <test compare="less" name="size" qual="any">
          <double>7</double>
        </test>
        <edit name="autohint" mode="assign">
            <bool>false</bool>
        </edit>
    </match>
-->
    <!-- end: Arial and Verdana -->


For more details, see How to apply autohinting selectively.
_________________
Regards

Chris Karakas
www.karakas-online.de
Back to top
View user's profile Send private message Send e-mail Visit poster's website
chris
Dark Lord of the Sith


Joined: 10 May 2003
Posts: 6267
Location: Outer Space

PostPosted: Wed Jul 02, 2008 9:03 am    Post subject:
Reply with quote

Finally, a few nice documents I stumbled upon during that "lengthy, painful search":



Recommended reading!
_________________
Regards

Chris Karakas
www.karakas-online.de
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Share this page: These icons link to social bookmarking sites where readers can share and discover new web pages.Digg  del.icio.us  tc.eserver.org  Blinklist  Furl  Reddit  Blogmarks  Magnolia  Sphere  Yahoo!  Google  Windows Live  Technorati  Blue Dot  Simpy  Newsvine  Stumble Upon  co.mments.com  Blinkbits  BlogMemes  Connotea 
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
   Chris Karakas Online Forum Index -> Linux Forum
Page 1 of 1
This page contains valid HTML 4.01 Transitional - click here to check it!
This page contains a valid CSS - click here to check it!

 

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group